on ADSL

ADSL non va di pomeriggio: spiegazione del perché

Adsl non funziona di pomeriggio: una guida per risolvere questo problema
Aiuto: la mia ADSL non va di pomeriggio!

E’ dagli ultimi mesi dello scorso anno che va avanti questa storia: alcuni lamentano problemi solo nel pomeriggio, altri fino a tarda sera. Ad alcuni in quei momenti va più lenta di un vecchio modem 56Kbit altri, i più "fortunati", hanno solo pochissima banda.

Ora cercherò di inquadrare bene la situazione.

A chi capita?

Sembrerebbe a tutti ma a guardare bene non è vero. Non va ad alcuni utenti Alice, non va ad alcuni utenti di altri ISP minori e non va neppure ad alcuni utenti degli altri ISP più grandi.

Verificando nel dettaglio si scopre che gli utenti Alice che hanno problemi sono invariabilmente quelli che passano sulla tratta ATM (ATM è una tecnologia di trasmissione datata e poco efficiente che Telecom Italia continua ad utilizzare).

Anche gli altri (non Alice) si scopre che hanno una linea che il loro ISP acquista all’ingrosso da Telecom Italia e queste linee, guarda caso, passano tutte su tratte ATM.

A chi NON capita? Non ho mai trovato un utente collegato con una linea in ULL (per semplificare una linea totalmente indipendente da Telecom Italia) che avesse problemi e neppure utenti Telecom connessi alla nuova rete FULL IP di Telecom Italia.

Cosa succede?

Per chi non è esperto la percezione è di una linea che sembra debba funzionare (tutte le lucine accese come dovrebbero) ma per aprire una pagina web si attende tempi biblici. Per i più esperti spesso la banda è ridotta e quasi sempre c’è un elevato tasso di pacchetti persi e latenza elevata.

Quando Succede?

Per alcuni inizia la mattina, ad altri parte il primo pomeriggio. In alcuni casi le problematiche terminano nel pomeriggio (più o meno tardo) o, addirittura, la notte!

La situazione reale

All’inizio di questa vicenda nessuno ci capiva nulla ma, poco dopo, i più esperti e i più addentro nelle strutture di rete Italiana hanno cominciato a capire quale potesse essere la causa di tutto ciò.

Un dato significativo è che un problema simile si era presentato tempo fa durante un upgrade gratuito di banda effettuato da Telecom Italia e anche questa volta capitava in corrispondenza dell’upgrade da 640Kbit a 2Mbit e più o meno insieme anche all’arrivo delle nuove linee da 20Mbit.

Nel frattempo il problema era diventato così imponente che Telecom Italia è stata costretta a dire qualcosa ed è uscita con una mezza (anzi 1/4) verità: ha addossato la colpa a malware che a loro dire avrebbero causato il problema.

Stendo un velo pietoso su quello che hanno fatto televisione e giornali riportando come oro colato le parole di Telecom Italia. E’ comprensibile (ma a parer mio inaccettabile) tant’è che anche autorevoli luoghi di informazione in internet non si sono discostati molto da quella linea. Addirittura alcuni blog sono stati titubanti: Telecom è grossa e cattiva e mette un po’ paura 😉

Non tutti: Stefano Quintarelli ha scritto, aggiungendo vari update, cose interessanti e ci sono anche molti commenti illuminanti.

Marco Giuliani ha scritto un articolo proprio sulla questione malware e anche un seguito.

Per non parlare di quello che è possibile leggere in questa chilometrica discussione sul forum di NGI (per i più pigri questo singolo post di Skyluke, aka Luca Spada che è l’amministratore delegato di NGI).

Qua e là sempre nel forum di NGI e in quello di HTML.IT si scoprono cose interessanti come anche singoli utenti che hanno parlato informalmente con tecnici Telecom Italia (e non) i quali confermano il problema. Per la cronaca anche io ho avuto modo di parlare con un tecnico di un ISP che ha confermato.

Se i link agli articoli e forum che ho messo vi annoiavano e non li avete seguiti vi faccio un riassunto.

Nonostante non siano da escludere problemi causati da malware, attacchi ddos e altre amenità simili la causa è la saturazione di alcuni snodi sulla rete ATM di Telecom Italia. Il fatto che causi problemi colpendo in maniera casuale non è strano. Ci sono casi di utenti che hanno ufficio e casa nella stessa città, stesso gestore per l’ADSL e da una parte va mentre dall’altra no.

Il dettaglio tecnico è questo: su alcuni tratte ATM la cpu di alcuni switch va in saturazione per il troppo traffico nonostante il traffico sia al di sotto del massimo che potrebbero sopportare (switch mal dimensionati?). Dato che ogni ADSL ha il suo instradamento può capitare che il tuo vicino di casa vada bene e tu no. L’instradamento lo possono cambiare solo i tecnici Telecom Italia e quando lo hanno fatto il problema, per quel cliente, si è magicamente risolto.

Peccato che se sposti troppi utenti su un percorso libero corri il rischio di intasarlo quindi la soluzione è un upgrade di molti punti della rete ATM o una massiccia migrazione verso la nuova rete FULL IP.

Con fatica le cose si sono sistemate e ora gli utenti che hanno ancora questo tipo di disservizio sono molti meno ma a me resta la rabbia per il fatto che in tanti non sappiano quale sia stata la vera causa!

(fonte della foto in testa all’articolo: Flickr )

scrivi un commento

Commento

Ricevi un avviso se ci sono nuovi commenti. Oppure iscriviti senza commentare.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.